更新exploit-db时报错error: RPC failed curl 56 LibreSSL SSL_read: SSL_ERROR_SYSCALL,
老眼 2018-06-28 15:05:43
分 享


【问题现象】


更新或安装exploit-database报错如下:


lysmacbookair:opt laoyan$ sudo git clone https://github.com/offensive-security/exploit-database.git /opt/exploit-database

Cloning into '/opt/exploit-database'...

remote: Counting objects: 106517, done.

remote: Compressing objects: 100% (45/45), done.

error: RPC failed; curl 56 LibreSSL SSL_read: SSL_ERROR_SYSCALL, errno 60

fatal: The remote end hung up unexpectedly

fatal: early EOF

fatal: index-pack failed


【问题原因】


该项目由于时代久远,所以导致整个项目比较复杂庞大。出现这种错误,就是因为curl的postBuffer默认值太小的原因,重新在终端配置一下这个值就可以了。


【解决方法】


lysmacbookair:opt laoyan$ git config --global http.postBuffer 114288000


修改此项后还出现上面的报错,则继续调大114288000 至更高的数字


lysmacbookair:exploit-database laoyan$ git config --list


查看到上面的修改值则修改成功了



吐槽一下

游客

所有吐槽
  • 暂时还没有吐槽,赶紧来吐槽!